TWIAY = Tips & triclks

February 25, 2010 — Tip MB001: How to incorporate custom toolbar buttons and custom cursors into your MapBasic application?

How to incorporate custom toolbar buttons and cursors into your
MapBasic application?

When you create your own MapBasic application, you might wish to In this explanation a free development kit will be used to create and edit

create a toolbar with your own custom buttons. Of ¢ ourse, you can the DLL: Pelles C

use one of the buttons which are provided with MapB asic

(ICONS.DEF), but then chances are high that your ap  plication uses

an icon which has been used by another developer in another @

application already... 2
Pelles C IDE

You want to use your own unique toolbar buttons. It is quite easy to

do so. So, if necessary: please feel free to download
(http://www.smorgasbordet.com/pellesc/) and install this development kit

You just store some bitmaps in a DLL, and you call this DLL from to be able to follow the steps below.

your application. This document will explain — step by step — how to

get there. You will see how easy it is to incorporate your own custom toolbar buttons

and your own custom cursors into your MapBasic application.
At the end of this document you will also find a de scription of how to
incorporate your own custom cursor.

o

This document has been updated for Maplnfo Professional 10.0.1 Eird ‘@i
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Step 1: Arrange software to create a DLL

You will need to create a DLL (a Dynamic Link Library) to store your
bitmaps. The MapBasic development environment does not offer you
the possibility to create and edit a DLL file.

You have got to use third-party software for this.

If you do not have any experience with creating and editing DLL files,
please have a look at this one: Pelles C

Pelles C is a complete development kit for Windows. And Pelles C is
available for free.

You can download Pelles C free of charge from the following
location: http://www.smorgasbordet.com/pellesc/

The installation of Pelles C is quite straightforward.

The first time you run Pelles C IDE you will be asked to create a
System definitions database.

(The following version of Pelles C IDE is used here:
Version 6.00.4 from August 2, 2009.)

Step 2: Create a DLL

Start Pelles C IDE and go to File > New > Project...

In the New project dialog, select from Empty projects the Win32
Dynamic library (DLL) , enter a name and click OK.

© TWIAV.NL — www.twiav.nl

New project |E“z‘

Select a project type, enter a name for the project, and click Ok, |ﬁ|
Template projects ]
Cansole Cuskom Impark MSYC Win3z Win3Z OLL - Win32 installer
applicati...  control wizard project applicati... wizard wizard

Empty projects

B 0% % -

Win3z2 Win3z2 'Win32Z Static  Win32 Console Wi

3

'WInCE Pocket
Program (EXE) Dynamicl...  library (LIB)  program (EXE) Installer PC Progra...
WinCE Pocket WinCE Pocket WinCE Pocket WinCE WinCE WwinCE
PC Dynami... PC3Staticli... PCInstaller  Smartphon...  Smartpho...  Smartpha... |
Iame: Bird | [ 0K ]
Location:  uments and SettingsiPitney Bowes\My DocumentsiPeles C Projects|Bird |E]
= Advanced
-

You now have an empty project.

(EIEE]

8=t

FL

Priect | Find infles | Oulput | Debug | Bieakpoins|
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Go to File > New > Source Code

You do need a source file to be able to build your DLL later on. But

don't be afraid: you are not going to enter a single line of code here.

Save the empty source file (File > Save)

Save As Elrzl

Save jm ‘BBild "| & ] u?' £2 [l

iy Recent
Documents

€}

Deskiop

My Documents

My Computer

File name: |B\rd V‘ |l Save J

MyMetwok | Saveastype: | Source fle (') | [ concel |

When asked to add this file to the current project, please answer
Yes.

Pelles C for Windows

1 : D you want ba add the File 'Bird o' ta the current project?
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Step 3: Create bitmaps

You must create two bitmap resources for each custom icon.

The first bitmap resource must be 16 (or 18) pixels wide by 16 pixels
high; this is the icon that will appear if the user does not check the
Large Buttons check box in MapInfo Professional’s Toolbar Options
dialog box.

The second bitmap resource must be 24 (or 26) pixels wide by 24
pixels tall; this is the icon that will appear if the user does check the
Large Buttons check box.

You must create both resources. (Note: you must create bitmap
resources, not icon resources.)

i bird_s.bmp - Paint

Attributes

File last saved: 22-2-201014:14
Size on disk: 950 bytes
Resolution; 102 » 85 dots per inch

widh: (18 Heicht |16

Units

O Inches (O Cm (&) Firels

Colars
() Black and white (%) Calors

a EEEFENEENEEEEE
ENE NE(E | (e

For Help, click Help Topics on the Help Menu,
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MapInfo Professional 10:
New MapBasic Capability for Custom Icons

Before Maplinfo Professional 10.0, custom icons were rectangular in
size: 18x16 for small icons and 26x24 for large icons. New toolbar
and menu features introduced in Maplnfo Professional 10.0 require
square icons: 16x16 for small icons and 24x24 for large icons.

When creating bitmap resources you've got to think with which
version of MaplInfo Professional your tool will be used:

For best results, recreate your icons to 16x16 for small icons and
24x24 for large icons. Icons at these sizes are not backwards
compatible and generate an error message in versions earlier than
10.0.1.

For backwards compatibility, use 18x16 for small icons and 26x24 for
large icons. But if you do so, please make sure you do not use the
first and last column of pixels, because from version 10.0.1 onwards
these columns of pixels will be removed to not display them
(cropping the image). In effect, the newest versions will just treat
your bitmaps as square icons - but for backwards compatibility there
has to be a blank column of pixels at the beginning and at the end.

Step 4: Add bitmaps to DLL

Now that you have your bitmaps, you have got to add them to your
DLL project.

Return to Pelles C IDE and choose File > New > Resources

Next, choose Resource > Import... to import your bitmaps.
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Import
Look in:
A
3

My Flecent
Documernts

Desktop

My Documents

Imnport as:

| Auta v

=1
J
My Computer
‘J File name: | "hird_g.bmp" "bird_|.brmp" b
) =
My Matwork, | Files of bope: | Fiesource files [ b, dif;” ico;” cur,” avi" ani v Cancel

Please make sure that sequential ID numbers are assigned to the
two bitmap resources.

In this example, an ID of 8001 was assigned to the small bitmap, and
an 1D of 8002 to the large bitmap. (This is done automatically by
Pelles C IDE )

Next, choose File > Save to save the Resource script.
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Savejn: | |9 Bid v O o

‘a
iy Recent
Documents

P‘F 3

L

Deskiop

My Documents

My Computer

File name: |B\rd v ‘ | Save j

My Metwork | Save as type: | Resource seript [*c) - i [ Cancel ]

And again, when asked to add this file to the current project, please
answer Yes.

Pelles C for Windows

1 Do you want to add the file 'Bird.rc’ to the current project?
e

You are ready to build your DLL now. No! Wait! Let's enter a Version
to be able to document your DLL a little bit.

Choose Resource > New > Version and enter the relevant
information.
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© Pelles € for Windows - [Bird.rc; #1 (Version)] EER
(] Fle Edt Yiew Project Jooks Window Help =

D-sua * H3 b
Bicic | Bidc | Bidsc #1 IVersion) | Biidic. #6001 (Bitmap) | Bird i HE00Z (Bitmap)
D Tet
FILEVERSION 1.0.0.0
PRODUCTVERSION 1.0.0.0
FILEFLAGSMASK 0
FILEFLAGS 00
FILEDS VOS_WINDOWS32
FILETYPE VET_APP
FILESUBTYPE VFTZ_ UNKNDWN
Version black Englih (Unied Stales) - Uricade (040904801
Deserplion DLL containing resatices for the BirdFegistation appication
File version 1000
Original name Bid
Internal nams Bid
Pioduct name Biid
Product version 1000
Company TWISV.NL
Capyright STWIAY.NL - 2010
Trademaks
Deeseriplon for pivate buld
Deescrplion for special buid
Cor

Project | Findin fies | Dutput | Debug | Breakpoints

Save your Resource script again.

Step 5: Build your DLL

Choose Project > Build <My own>.dll  to build your own DLL.

You will get a warning — something about an empty input file (your
empty source file) — but the DLL will be created anyhow.

Only five simple steps! Now you have got your DLL with the bitmaps
to use as custom toolbar buttons.

Bird.dll
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Step 6: Call the DLL from your application

Once you have created the pair of bitmap resources, you can
incorporate your custom bitmaps into your MapBasic application

using either a Create ButtonPad or an Alter ButtonPad statement.

In your program, refer to the ID of the smaller bitmap resource. In
this example, the IDs 8001 and 8002 where assigned to the bitmap
resources, so the program should refer to ID 8001, as shown in the
following statement:

Create ButtonPad "Bird Regi stration" as

Tool Button
Icon 8001 File "Bird.dlI"
Hel pMsg "Regi ster a bird\nBird"
Dr awMbde DM CUSTOM PO NT
Cursor M _CURSOR_FI NGER _LEFT
Calling Registration

Show

The DLL file where you store your custom icons (in this example,
Bird.dIl) must be installed on your user’s system, along with the
.MBX file. The DLL file can be installed in any of the following
locations:

* The directory where the .MBX file is located;

» the directory where the Maplinfo Professional software is

installed;

» the user's Windows directory;

» the system directory within the Windows directory;

« or anywhere along the user’s search path.
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If you place the DLL in any other location, your MapBasic program
must specify the directory path explicitly (for example, Icon 100 File
"C:\GIS\MBICONS1.DLL").

Note that the ProgramDirectory$() and ApplicationDirectory$( )
functions can help you build directory paths relative to the Maplnfo
Professional directory or relative to the directory path where your
MBX is installed.

Step 7: Run your application

Here you are! Your own custom tool button.

Disabling toolbar buttons

And this what your button looks like in MapInfo Professional 10 when
it is disabled (“grayed out”)
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Disabling toolbar buttons in older versions of MaplInfo
Professional

If you want your tool buttons to be backwards compatible, please What happens if you do not use one of the colors mentioned above?
note that graying out works a little different in older versions of
Maplnfo Professional. See the example below: Let’s test this. Here you can see the same button as before, but now

with an olive border (R=128, G=128, B=0).

It looks great when enabled...

If you want your application to be able to disable (“gray out”) your
toolbar button — e.g. if you do not want it to be available under
certain conditions — then please make sure that you use a dark
boundary line around your picture.

In the example a maroon line was used. And this is how it looks like
when “grayed out”:

At least the following colors can be used for this purpose:
Black (R=0, G=0, B=0)

Navy (R=0, G=0, B=128)
Maroon (R=128, G=0, B=0)
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Step 8: Let’s also add a custom cursor!

Pelles C also offers the possibility to create and edit cursor files
(*.cur).

So, let us also add a custom cursor:
Choose Resource > New > Cursor and draw your own cursor.

(As you will see the cursor also gets the ID 8001 — but that's not a
problem, because a cursor is not a bitmap)

Please make sure to make the beak the hotspot and to use the
screen color for the background of your cursor.

© Pelles € for Windows - [Bird.rc; #8001 (Cursor)] FE®E
9] Fle Edt View Project Inage ook Window Help =] ¢
D-ESWd %¥Ra@d|9 HS b b

| Bird o Bidc | Bidic. #8002 (Bimap) | Bid ic. #8001 (Bitmap) | Birdro: #8001 (Cursol] |

v files | Dutput | Debug | Breakpaints

4: [IS0] Empty input file.

0,24

After finishing your cursor design, save your Resource script again
and rebuild your DLL.
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Now you can refer to the cursor in the DLL from your application (see
code below):

Create ButtonPad "Bird Registration" as

Tool Button
Icon 8001 File "Bird.dll"
Hel pMsg "Regi ster a bird\nBird"
Dr awbde DM CUSTOM PO NT
Cursor 8001 File "Bird.dlI"
Calling Registration

Show

Step 9: Run your application again

Here you are! Your own custom cursor

Happy coding!
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